Bug #134

make font bigger/smaller leads to something unreadable, in both cases.

Added by Axel Belinfante over 11 years ago. Updated over 11 years ago.

Status:ClosedStart date:19 Jun 2009
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:1.1.0

Description

(this report refers to use on windows)


Related issues

Related to JTorX - Bug #141: when fonts are made bigger, items in e.g. Config pane bec... Closed 24 Jun 2009
Related to JTorX - Bug #143: tree/table headers are unaffected by font changes, at lea... Resolved 24 Jun 2009

History

#1 Updated by Axel Belinfante over 11 years ago

confirmed that with 1.0.0 on windows text becomes unreadable, i.e.
on first change the text is changed to a very small font, also when we press 'make text bigger', however:
  • the Check button in the UtracesChecker tab changes in the way that we want:
    it does not shrink like all other text does, even the text in the 'Simulate selected trace' button next to it does shrink
  • eventually, after we have pressed 'make text bigger' often enough, the shrunken text also becomes bigger
    (and the UtracesChec pane Check button becomes huge)

#2 Updated by Axel Belinfante over 11 years ago

  • Status changed from New to Closed
  • Target version set to 1.1.0
  • % Done changed from 0 to 100

fixed in commit e4597b1ce14f13428c8daadd7f0a8b783c08ebf4

potential issue, that we ignore for now: we do not correctly treat the case when we there are multiple FontData items associated with a Font.

remaining issue, for which we create a separate issue: our own PaneContainer layout items do not notice that the widgets that they contain have changed in size (due to font size changes).

#3 Updated by Axel Belinfante over 11 years ago

  • Status changed from Closed to Resolved
  • % Done changed from 100 to 90

turns out that headers of tree or table widgets are not affected by font changes.

for now I do not care (this note should help us to not forget).
(because of that, also: status reverted to Resolved; done 90%)

#4 Updated by Axel Belinfante over 11 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 90 to 100

added new item for the headers issue (which we cannot solve: swt implementation issue)

changed back to closed, 100%

in the mean time, improved the font changing code in commit 53e082fc00c6a7b30b6241e1e9d3a2c24e35ae4e

Also available in: Atom PDF