Bug #448

confusing error message when instantiating already instantiated item

Added by Axel Belinfante over 9 years ago. Updated over 9 years ago.

Status:FeedbackStart date:07 Dec 2010
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:1.7.1

Description

Trying out the sts05.sax example I want to get an instantiation for the
initial input:
?read(foo@enum)
But pressing "Get" gives the message
"failed to obtain instantiation"
The reason is:
fatal: explorer error:F0 already instantiated
This makes sense, since the (only) solution has already been instantiated.
Though, the error message is a bit confusing, one would probably expect to get
the only, already instantiated solution back when pressing "Get".

(reported by Lars)


Related issues

Related to JTorX - Bug #370: "Use Instantiation" button is always enabled Feedback 28 May 2010

History

#1 Updated by Axel Belinfante over 9 years ago

An alternative solution that I think I like even more, would be to disable the "Get" and "Use" buttons when there is nothing to instantiate resp. there is no instantiation result to be used.

#2 Updated by Axel Belinfante over 9 years ago

enabling/disabling of "Get" and "Use" buttons has been added (and then fixed) in commits cf4823513724e1ed1ef9c46cc0d76a0500c1a615 and 5869fd54db250c27a88434f94450f1444d3b5814

#3 Updated by Axel Belinfante over 9 years ago

  • Target version set to 1.7.1
  • % Done changed from 0 to 100

#4 Updated by Axel Belinfante over 9 years ago

  • Status changed from New to Feedback

Also available in: Atom PDF